summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-12-06 16:19:14 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2018-12-06 16:33:46 -0800
commit26a8643ad5c5d9e75354da09a624c675be9c73a0 (patch)
tree439466a0f48e0782a36f44c34c50fcae9c3cb525
parent19ec3b30752bbd797653cf330ca6932e05cba5a6 (diff)
downloadredis-py-26a8643ad5c5d9e75354da09a624c675be9c73a0.tar.gz
Use tox "extras" option to install package extras
For details, see: https://tox.readthedocs.io/en/latest/config.html#conf-extras Removes the need to duplicate the version string in tox.ini. Allow setup.py to be the single source of truth.
-rw-r--r--tox.ini5
1 files changed, 3 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 82f8976..c5e3e97 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,12 +1,13 @@
[tox]
-minversion = 1.8
+minversion = 2.4
envlist = {py27,py34,py35,py36,py37}-{plain,hiredis}, pycodestyle
[testenv]
deps =
mock
pytest >= 2.7.0
- hiredis: hiredis >= 0.1.3
+extras =
+ hiredis: hiredis
commands = py.test {posargs}
[testenv:pycodestyle]