summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2017-11-02 06:30:07 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2018-11-03 03:21:49 -0700
commit5d1c1f767f9004cae670451da56d62bcb4550111 (patch)
treed81f05482b0e74a653680e9808be9acedd2d341d
parent350362405112d6047ade4c3cc81931a2b4e33e36 (diff)
downloadredis-py-5d1c1f767f9004cae670451da56d62bcb4550111.tar.gz
Remove support and testing for EOL Python 2.6
Python 2.6 is EOL. It is no longer receiving bug fixes, including for security issues. It has been EOL since 2013-10-29. For additional details of the status of Python versions, see: https://devguide.python.org/#status-of-python-branches For discussions on why removing Python 2.6 benefits the entire community, please see: https://snarky.ca/stop-using-python-2-6/ http://www.curiousefficiency.org/posts/2015/04/stop-supporting-python26.html
-rw-r--r--.travis.yml1
-rw-r--r--CHANGES2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
4 files changed, 3 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 4c4e951..b0ac608 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,7 +6,6 @@ python:
- "3.4"
- "3.3"
- "2.7"
- - "2.6"
before_install:
- wget http://download.redis.io/releases/redis-5.0.0.tar.gz && mkdir redis_install && tar -xvzf redis-5.0.0.tar.gz -C redis_install && cd redis_install/redis-5.0.0 && make && src/redis-server --daemonize yes && cd ../..
- redis-cli info
diff --git a/CHANGES b/CHANGES
index f38cd44..db81c79 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,5 @@
+* UNRELEASED
+ * Removed support for EOL Python 2.6.
* 2.10.6
* Various performance improvements. Thanks cjsimpson
* Fixed a bug with SRANDMEMBER where the behavior for `number=0` did
diff --git a/setup.py b/setup.py
index da0afc5..6838fe8 100644
--- a/setup.py
+++ b/setup.py
@@ -62,7 +62,6 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
diff --git a/tox.ini b/tox.ini
index ab7cb7c..64abccb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
minversion = 1.8
-envlist = {py26,py27,py33,py34,py35,py36}-{plain,hiredis}, pycodestyle
+envlist = {py27,py33,py34,py35,py36}-{plain,hiredis}, pycodestyle
[testenv]
deps =