summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy McCurdy <andy@andymccurdy.com>2018-11-06 13:38:25 -0800
committerAndy McCurdy <andy@andymccurdy.com>2018-11-06 13:38:25 -0800
commit3e7a1e1f1618b7807d6725ae7537b14e0aff7b7f (patch)
tree625bcf9bd000df646ba471a7ef01b41896bba939
parent74d49ba705f3dd3bc374d8868c0e889674edce13 (diff)
downloadredis-py-3e7a1e1f1618b7807d6725ae7537b14e0aff7b7f.tar.gz
test python3.7 on travis
-rw-r--r--.travis.yml22
1 files changed, 16 insertions, 6 deletions
diff --git a/.travis.yml b/.travis.yml
index fb0f9fd..10070e5 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,10 +1,10 @@
language: python
cache: pip
python:
- - "3.6"
- - "3.5"
- - "3.4"
- - "2.7"
+ - 3.6
+ - 3.5
+ - 3.4
+ - 2.7
before_install:
- wget http://download.redis.io/releases/redis-5.0.0.tar.gz && mkdir redis_install && tar -xvzf redis-5.0.0.tar.gz -C redis_install && cd redis_install/redis-5.0.0 && make && src/redis-server --daemonize yes && cd ../..
- redis-cli info
@@ -18,7 +18,17 @@ install:
script: "if [[ $TEST_PYCODESTYLE == '1' ]]; then pycodestyle --repeat --show-source --exclude=.venv,.tox,dist,docs,build,*.egg,redis_install .; else python setup.py test; fi"
matrix:
include:
- - python: "2.7"
+ - python: 2.7
env: TEST_PYCODESTYLE=1
- - python: "3.6"
+ - python: 3.6
env: TEST_PYCODESTYLE=1
+ # python 3.7 has to be specified manually in the matrix
+ # https://github.com/travis-ci/travis-ci/issues/9815
+ - python: 3.7
+ dist: xenial
+ sudo: true
+ env: TEST_HIREDIS=0
+ - python: 3.7
+ dist: xenial
+ sudo: true
+ env: TEST_HIREDIS=1