summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-01-05 05:47:36 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2018-11-03 03:21:49 -0700
commitba79979a46c63355b81b24e769200e5b65507b84 (patch)
treee6018d4cdc96afc695b5ecd39642dfd078e4bc2a
parent2909d281b9f451a36ae949c3a433423b6f85b116 (diff)
downloadredis-py-ba79979a46c63355b81b24e769200e5b65507b84.tar.gz
Pass python_requires argument to setuptools
Helps pip decide what version of the library to install. https://packaging.python.org/tutorials/distributing-packages/#python-requires > If your project only runs on certain Python versions, setting the > python_requires argument to the appropriate PEP 440 version specifier > string will prevent pip from installing the project on other Python > versions. https://setuptools.readthedocs.io/en/latest/setuptools.html#new-and-changed-setup-keywords > python_requires > > A string corresponding to a version specifier (as defined in PEP 440) > for the Python version, used to specify the Requires-Python defined in > PEP 345.
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9a87d66..edc1b41 100644
--- a/setup.py
+++ b/setup.py
@@ -44,6 +44,7 @@ setup(
keywords=['Redis', 'key-value store'],
license='MIT',
packages=['redis'],
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
extras_require={
'hiredis': [
"hiredis>=0.1.3",