summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@whiskeymedia.com>2013-04-27 13:09:41 -0700
committerandy <andy@whiskeymedia.com>2013-04-27 13:09:41 -0700
commitbcd8552c8d536f781da84f732bb73219bb056268 (patch)
tree3928e9af5a259bc7c716cb87fac8c5779627a8b8
parentf6f92527298ecf0eff3c103113677a36e606bd07 (diff)
downloadredis-py-bcd8552c8d536f781da84f732bb73219bb056268.tar.gz
more weird pep8 travis hacking
-rw-r--r--.travis.yml7
1 files changed, 4 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index fc76e6d..89731a4 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,9 +5,10 @@ python:
- "2.7"
- "2.6"
- "2.5"
+env:
+ - PEP8=0
+ - PEP8=1
install:
- pip install pep8 --use-mirrors
- pip install -e . --use-mirrors
-before_script:
- - "pep8 --repeat --show-source --exclude=.venv,.tox,dist,doc,build,*.egg ."
-script: python setup.py test
+script: "if [[ $PEP8 == '1' ]]; then pip install pep8 --use-mirrors; pep8 --repeat --show-source --exclude=.venv,.tox,dist,doc,build,*.egg . else python setup.py test fi"