summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Brookins <andrew.brookins@redislabs.com>2020-07-13 23:14:26 +0000
committerAndrew Brookins <andrew.brookins@redislabs.com>2020-07-13 23:14:26 +0000
commita10751d94bbf2dd9bfc2f8946f5a3934df41b346 (patch)
tree9fad6320d81d19ee4d5b0b550075784460647022
parent639a8dc11858f87ee571791bb751315de690541b (diff)
downloadredis-py-a10751d94bbf2dd9bfc2f8946f5a3934df41b346.tar.gz
Improvements based on review feedback:
1. All make targets are now PHONY. 2. Cleaned up the 'dev' target so that it passes --build to docker-compose. 3. Added pypy-specific tox environments. And added a new Dockerfile to build an image for the "test" container that contains pypy and pypy3. 4. Added a `make clean` target. It removes containers but requires the user to confirm. 5. Specify the depends_on order for slave -> master and made all sentinels depend on the slave coming up. The container running doesn't mean that redis is actually ready though, so I wrapped the "test" target in the Makefile with a wait script that waits until master is responding on port 6379.
-rw-r--r--Makefile14
-rw-r--r--docker-compose.yml12
-rw-r--r--docker/test/Dockerfile3
-rw-r--r--tox.ini12
-rwxr-xr-xutil/wait-for-it.sh183
5 files changed, 217 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 54d2db1..d64d440 100644
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,14 @@
.PHONY: build dev test
-build:
+base:
docker build -t redis-py-base docker/base
- docker-compose build
-dev:
- docker-compose up -d
+dev: base
+ docker-compose up -d --build
test: dev
- find . -name "*.pyc" -exec rm -f {} \;
- docker-compose run test tox -- --redis-url=redis://master:6379/9
+ docker-compose run test util/wait-for-it.sh master:6379 -- tox -- --redis-url=redis://master:6379/9
+
+clean:
+ docker-compose stop
+ docker-compose rm
diff --git a/docker-compose.yml b/docker-compose.yml
index c7a7c0a..12d92b6 100644
--- a/docker-compose.yml
+++ b/docker-compose.yml
@@ -8,26 +8,36 @@ services:
slave:
build: docker/slave
+ depends_on:
+ - "master"
ports:
- "6380:6380"
sentinel_1:
build: docker/sentinel_1
+ depends_on:
+ - "slave"
ports:
- "26379:26379"
sentinel_2:
build: docker/sentinel_2
+ depends_on:
+ - "slave"
ports:
- "26380:26380"
sentinel_3:
build: docker/sentinel_3
+ depends_on:
+ - "slave"
ports:
- "26381:26381"
test:
- image: fkrull/multi-python:latest
+ build: docker/test
working_dir: /redis-py
+ depends_on:
+ - "sentinel_3"
volumes:
- .:/redis-py
diff --git a/docker/test/Dockerfile b/docker/test/Dockerfile
new file mode 100644
index 0000000..768b081
--- /dev/null
+++ b/docker/test/Dockerfile
@@ -0,0 +1,3 @@
+FROM fkrull/multi-python:latest
+
+RUN apt install -y pypy pypy3
diff --git a/tox.ini b/tox.ini
index 9518954..da92df6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -17,3 +17,15 @@ deps = flake8
commands = flake8
skipsdist = true
skip_install = true
+
+[testenv:pypy-plain]
+basepython = pypy
+
+[testenv:pypy-hiredis]
+basepython = pypy
+
+[testenv:pypy3-plain]
+basepython = pypy3
+
+[testenv:pypy3-hiredis]
+basepython = pypy3
diff --git a/util/wait-for-it.sh b/util/wait-for-it.sh
new file mode 100755
index 0000000..b931da1
--- /dev/null
+++ b/util/wait-for-it.sh
@@ -0,0 +1,183 @@
+#!/usr/bin/env bash
+# Use this script to test if a given TCP host/port are available
+
+WAITFORIT_cmdname=${0##*/}
+
+echoerr() { if [[ $WAITFORIT_QUIET -ne 1 ]]; then echo "$@" 1>&2; fi }
+
+usage()
+{
+ cat << USAGE >&2
+Usage:
+ $WAITFORIT_cmdname host:port [-s] [-t timeout] [-- command args]
+ -h HOST | --host=HOST Host or IP under test
+ -p PORT | --port=PORT TCP port under test
+ Alternatively, you specify the host and port as host:port
+ -s | --strict Only execute subcommand if the test succeeds
+ -q | --quiet Don't output any status messages
+ -t TIMEOUT | --timeout=TIMEOUT
+ Timeout in seconds, zero for no timeout
+ -- COMMAND ARGS Execute command with args after the test finishes
+USAGE
+ exit 1
+}
+
+wait_for()
+{
+ if [[ $WAITFORIT_TIMEOUT -gt 0 ]]; then
+ echoerr "$WAITFORIT_cmdname: waiting $WAITFORIT_TIMEOUT seconds for $WAITFORIT_HOST:$WAITFORIT_PORT"
+ else
+ echoerr "$WAITFORIT_cmdname: waiting for $WAITFORIT_HOST:$WAITFORIT_PORT without a timeout"
+ fi
+ WAITFORIT_start_ts=$(date +%s)
+ while :
+ do
+ if [[ $WAITFORIT_ISBUSY -eq 1 ]]; then
+ nc -z $WAITFORIT_HOST $WAITFORIT_PORT
+ WAITFORIT_result=$?
+ else
+ (echo > /dev/tcp/$WAITFORIT_HOST/$WAITFORIT_PORT) >/dev/null 2>&1
+ WAITFORIT_result=$?
+ fi
+ if [[ $WAITFORIT_result -eq 0 ]]; then
+ WAITFORIT_end_ts=$(date +%s)
+ echoerr "$WAITFORIT_cmdname: $WAITFORIT_HOST:$WAITFORIT_PORT is available after $((WAITFORIT_end_ts - WAITFORIT_start_ts)) seconds"
+ break
+ fi
+ sleep 1
+ done
+ return $WAITFORIT_result
+}
+
+wait_for_wrapper()
+{
+ # In order to support SIGINT during timeout: http://unix.stackexchange.com/a/57692
+ if [[ $WAITFORIT_QUIET -eq 1 ]]; then
+ timeout $WAITFORIT_BUSYTIMEFLAG $WAITFORIT_TIMEOUT $0 --quiet --child --host=$WAITFORIT_HOST --port=$WAITFORIT_PORT --timeout=$WAITFORIT_TIMEOUT &
+ else
+ timeout $WAITFORIT_BUSYTIMEFLAG $WAITFORIT_TIMEOUT $0 --child --host=$WAITFORIT_HOST --port=$WAITFORIT_PORT --timeout=$WAITFORIT_TIMEOUT &
+ fi
+ WAITFORIT_PID=$!
+ trap "kill -INT -$WAITFORIT_PID" INT
+ wait $WAITFORIT_PID
+ WAITFORIT_RESULT=$?
+ if [[ $WAITFORIT_RESULT -ne 0 ]]; then
+ echoerr "$WAITFORIT_cmdname: timeout occurred after waiting $WAITFORIT_TIMEOUT seconds for $WAITFORIT_HOST:$WAITFORIT_PORT"
+ fi
+ return $WAITFORIT_RESULT
+}
+
+# process arguments
+while [[ $# -gt 0 ]]
+do
+ case "$1" in
+ *:* )
+ WAITFORIT_hostport=(${1//:/ })
+ WAITFORIT_HOST=${WAITFORIT_hostport[0]}
+ WAITFORIT_PORT=${WAITFORIT_hostport[1]}
+ shift 1
+ ;;
+ --child)
+ WAITFORIT_CHILD=1
+ shift 1
+ ;;
+ -q | --quiet)
+ WAITFORIT_QUIET=1
+ shift 1
+ ;;
+ -s | --strict)
+ WAITFORIT_STRICT=1
+ shift 1
+ ;;
+ -h)
+ WAITFORIT_HOST="$2"
+ if [[ $WAITFORIT_HOST == "" ]]; then break; fi
+ shift 2
+ ;;
+ --host=*)
+ WAITFORIT_HOST="${1#*=}"
+ shift 1
+ ;;
+ -p)
+ WAITFORIT_PORT="$2"
+ if [[ $WAITFORIT_PORT == "" ]]; then break; fi
+ shift 2
+ ;;
+ --port=*)
+ WAITFORIT_PORT="${1#*=}"
+ shift 1
+ ;;
+ -t)
+ WAITFORIT_TIMEOUT="$2"
+ if [[ $WAITFORIT_TIMEOUT == "" ]]; then break; fi
+ shift 2
+ ;;
+ --timeout=*)
+ WAITFORIT_TIMEOUT="${1#*=}"
+ shift 1
+ ;;
+ --)
+ shift
+ WAITFORIT_CLI=("$@")
+ break
+ ;;
+ --help)
+ usage
+ ;;
+ *)
+ echoerr "Unknown argument: $1"
+ usage
+ ;;
+ esac
+done
+
+if [[ "$WAITFORIT_HOST" == "" || "$WAITFORIT_PORT" == "" ]]; then
+ echoerr "Error: you need to provide a host and port to test."
+ usage
+fi
+
+WAITFORIT_TIMEOUT=${WAITFORIT_TIMEOUT:-15}
+WAITFORIT_STRICT=${WAITFORIT_STRICT:-0}
+WAITFORIT_CHILD=${WAITFORIT_CHILD:-0}
+WAITFORIT_QUIET=${WAITFORIT_QUIET:-0}
+
+# Check to see if timeout is from busybox?
+WAITFORIT_TIMEOUT_PATH=$(type -p timeout)
+WAITFORIT_TIMEOUT_PATH=$(realpath $WAITFORIT_TIMEOUT_PATH 2>/dev/null || readlink -f $WAITFORIT_TIMEOUT_PATH)
+
+WAITFORIT_BUSYTIMEFLAG=""
+if [[ $WAITFORIT_TIMEOUT_PATH =~ "busybox" ]]; then
+ WAITFORIT_ISBUSY=1
+ # Check if busybox timeout uses -t flag
+ # (recent Alpine versions don't support -t anymore)
+ if timeout &>/dev/stdout | grep -q -e '-t '; then
+ WAITFORIT_BUSYTIMEFLAG="-t"
+ fi
+else
+ WAITFORIT_ISBUSY=0
+fi
+
+if [[ $WAITFORIT_CHILD -gt 0 ]]; then
+ wait_for
+ WAITFORIT_RESULT=$?
+ exit $WAITFORIT_RESULT
+else
+ if [[ $WAITFORIT_TIMEOUT -gt 0 ]]; then
+ wait_for_wrapper
+ WAITFORIT_RESULT=$?
+ else
+ wait_for
+ WAITFORIT_RESULT=$?
+ fi
+fi
+
+if [[ $WAITFORIT_CLI != "" ]]; then
+ if [[ $WAITFORIT_RESULT -ne 0 && $WAITFORIT_STRICT -eq 1 ]]; then
+ echoerr "$WAITFORIT_cmdname: strict mode, refusing to execute subprocess"
+ exit $WAITFORIT_RESULT
+ fi
+ exec "${WAITFORIT_CLI[@]}"
+else
+ exit $WAITFORIT_RESULT
+fi
+