summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-01-05 06:17:34 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2018-11-03 03:21:49 -0700
commit2f20d279d252c67d932d4c1c87d76472a14497ba (patch)
treeba8dbbbd9a9dddad33e0f45d58e1ac3eeb9164c8
parentba79979a46c63355b81b24e769200e5b65507b84 (diff)
downloadredis-py-2f20d279d252c67d932d4c1c87d76472a14497ba.tar.gz
Unpin test dependencies
Now that redis-py has removed support for EOL Pythons, can once again run tests using the latest version of pytest.
-rw-r--r--setup.py2
-rw-r--r--tox.ini4
2 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index edc1b41..1e24ddd 100644
--- a/setup.py
+++ b/setup.py
@@ -52,7 +52,7 @@ setup(
},
tests_require=[
'mock',
- 'pytest>=2.5.0',
+ 'pytest>=2.7.0',
],
cmdclass={'test': PyTest},
classifiers=[
diff --git a/tox.ini b/tox.ini
index 3437348..8b851de 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,8 +4,8 @@ envlist = {py27,py34,py35,py36}-{plain,hiredis}, pycodestyle
[testenv]
deps =
- pytest==2.9.2
- mock==2.0.0
+ mock
+ pytest >= 2.7.0
hiredis: hiredis >= 0.1.3
commands = py.test {posargs}