summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2019-11-12 09:47:49 -0800
committerAndy McCurdy <andy@andymccurdy.com>2019-11-12 09:47:49 -0800
commita7d4a6c1f19201dc196d4ba4636227c49d733cd1 (patch)
treef837bcb562c5f138908a8eac16be5a3052248f43 /tox.ini
parent375839679e5faf1cf8fda4ce822284dcb664b1b9 (diff)
downloadredis-py-a7d4a6c1f19201dc196d4ba4636227c49d733cd1.tar.gz
Unify tox and Travis test matrix (#1243)
tox can now always be used as the test entry point and allows for contributors to easily test the full test matrix locally. Starting with setuptools v41.5.0 (27 Oct 2019) the `setup.py test` command is formally deprecated. It now emits a warning on use. Prior to this version, it use was discouraged by the setuptools developers. Now, always use tox as the one testing entry point. It handles multiple version of Python and Redis. The Travis CI configuration was reworked to use tox to install dependencies and run tests in the same manner that contributors would do locally.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini3
1 files changed, 2 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index f876f1c..a4fe50e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,11 +4,12 @@ envlist = {py27,py34,py35,py36,py37,py38}-{plain,hiredis}, pycodestyle
[testenv]
deps =
+ coverage
mock
pytest >= 2.7.0
extras =
hiredis: hiredis
-commands = py.test {posargs}
+commands = {envpython} -m coverage run -m pytest {posargs}
[testenv:pycodestyle]
basepython = python3.6