summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xredis/client.py8
-rw-r--r--setup.cfg37
-rw-r--r--setup.py47
3 files changed, 42 insertions, 50 deletions
diff --git a/redis/client.py b/redis/client.py
index 1393a1c..07aa9f6 100755
--- a/redis/client.py
+++ b/redis/client.py
@@ -3841,8 +3841,8 @@ class Pipeline(Redis):
# indicates the user should retry this transaction.
if self.watching:
self.reset()
- raise WatchError("A ConnectionError occured on while watching "
- "one or more keys")
+ raise WatchError("A ConnectionError occurred on while "
+ "watching one or more keys")
# if retry_on_timeout is not set, or the error is not
# a TimeoutError, raise it
if not (conn.retry_on_timeout and isinstance(e, TimeoutError)):
@@ -4019,8 +4019,8 @@ class Pipeline(Redis):
# since this connection has died. raise a WatchError, which
# indicates the user should retry this transaction.
if self.watching:
- raise WatchError("A ConnectionError occured on while watching "
- "one or more keys")
+ raise WatchError("A ConnectionError occurred on while "
+ "watching one or more keys")
# if retry_on_timeout is not set, or the error is not
# a TimeoutError, raise it
if not (conn.retry_on_timeout and isinstance(e, TimeoutError)):
diff --git a/setup.cfg b/setup.cfg
index 656df62..0a5d8e7 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,40 @@
+[metadata]
+name = redis
+version = attr: redis.__version__
+description = Python client for Redis key-value store
+long_description = file: README.rst
+url = https://github.com/andymccurdy/redis-py
+author = Andy McCurdy
+author_email = sedrik@gmail.com
+maintainer = Andy McCurdy
+maintainer_email = sedrik@gmail.com
+keywords = Redis, key-value store
+license = MIT
+classifiers =
+ Development Status :: 5 - Production/Stable
+ Environment :: Console
+ Intended Audience :: Developers
+ License :: OSI Approved :: MIT License
+ Operating System :: OS Independent
+ Programming Language :: Python
+ Programming Language :: Python :: 2
+ Programming Language :: Python :: 2.7
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3.5
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: 3.8
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: Implementation :: PyPy
+
+
+[options]
+packages = redis
+python_requires = >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*
+
+[options.extras_require]
+hiredis = hiredis>=0.1.3
+
[pycodestyle]
show-source = 1
exclude = .venv,.tox,dist,docs,build,*.egg,redis_install
diff --git a/setup.py b/setup.py
index d1f4e44..c823345 100644
--- a/setup.py
+++ b/setup.py
@@ -1,49 +1,4 @@
#!/usr/bin/env python
-import os
from setuptools import setup
-from redis import __version__
-
-
-f = open(os.path.join(os.path.dirname(__file__), 'README.rst'))
-long_description = f.read()
-f.close()
-
-setup(
- name='redis',
- version=__version__,
- description='Python client for Redis key-value store',
- long_description=long_description,
- long_description_content_type='text/x-rst',
- url='https://github.com/andymccurdy/redis-py',
- author='Andy McCurdy',
- author_email='sedrik@gmail.com',
- maintainer='Andy McCurdy',
- maintainer_email='sedrik@gmail.com',
- keywords=['Redis', 'key-value store'],
- license='MIT',
- packages=['redis'],
- python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*",
- extras_require={
- 'hiredis': [
- "hiredis>=0.1.3",
- ],
- },
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: Implementation :: CPython',
- 'Programming Language :: Python :: Implementation :: PyPy',
- ]
-)
+setup()