summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 0 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index 18588da..04ad33a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,25 +1,10 @@
#!/usr/bin/env python
import os
-import sys
from setuptools import setup
-from setuptools.command.test import test as TestCommand
from redis import __version__
-class PyTest(TestCommand):
- def finalize_options(self):
- TestCommand.finalize_options(self)
- self.test_args = []
- self.test_suite = True
-
- def run_tests(self):
- # import here, because outside the eggs aren't loaded
- import pytest
- errno = pytest.main(self.test_args)
- sys.exit(errno)
-
-
f = open(os.path.join(os.path.dirname(__file__), 'README.rst'))
long_description = f.read()
f.close()
@@ -44,11 +29,6 @@ setup(
"hiredis>=0.1.3",
],
},
- tests_require=[
- 'mock',
- 'pytest>=2.7.0',
- ],
- cmdclass={'test': PyTest},
classifiers=[
'Development Status :: 5 - Production/Stable',
'Environment :: Console',