summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-11-12 17:21:15 -0500
committerTres Seaver <tseaver@palladion.com>2016-11-12 17:21:30 -0500
commitf2c531752cdb363b318cdce77c17157412491a75 (patch)
treebe46ae644c987b7a9795c098c47b531f3da3d3fc
parent79d599cab1baaa3205cd10da2d4b13bf1a047635 (diff)
downloadrepoze-lru-f2c531752cdb363b318cdce77c17157412491a75.tar.gz
Get next version right.
Add explicit support for Python 3.4, 3.5 and PyPy3. Drop support for Python 2.6 and 3.2.
-rw-r--r--CHANGES.txt8
-rw-r--r--setup.py7
-rw-r--r--tox.ini13
3 files changed, 13 insertions, 15 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 0a21015..b95392c 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,15 +1,17 @@
Changelog
=========
-After 0.6
----------
+0.7 (unreleased)
+----------------
- Expose cache object on the wrapped function, e.g. to allow extracting cache
performance data easily (PR #20).
- Avoid crash when memoizing a ``functools.partial`` instance (PR #21).
-- Added explicit support for Python 3.3.
+- Add explicit support for Python 3.3, 3.4, and 3.5.
+
+- Drop support for Python 2.6 and 3.2.
0.6 (2012-07-12)
----------------
diff --git a/setup.py b/setup.py
index ed1a589..c6a1f71 100644
--- a/setup.py
+++ b/setup.py
@@ -27,17 +27,18 @@ except:
testing_extras = ['nose', 'coverage']
setup(name='repoze.lru',
- version='0.7.1',
+ version='0.7dev0',
description='A tiny LRU cache implementation and decorator',
long_description=README + '\n\n' + CHANGES,
classifiers=[
"Intended Audience :: Developers",
"Programming Language :: Python",
- "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"License :: Repoze Public License",
diff --git a/tox.ini b/tox.ini
index ecb24ed..8b8aad2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,22 +1,17 @@
[tox]
envlist =
- py26,py27,py32,py33,pypy,cover,docs
+ py27,py33,py34,py35,pypy,pypy3,cover,docs
[testenv]
commands =
- python setup.py test -q
-deps =
- setuptools-git
- virtualenv
+ python setup.py -q test -q
[testenv:cover]
basepython =
- python2.6
+ python2.7
commands =
nosetests --with-xunit --with-xcoverage
deps =
- setuptools-git
- virtualenv
nose
coverage
nosexcover
@@ -27,7 +22,7 @@ deps =
[testenv:docs]
basepython =
- python2.6
+ python2.7
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest