summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Haritonov <reclosedev@gmail.com>2012-05-04 15:51:19 +0400
committerRoman Haritonov <reclosedev@gmail.com>2012-05-04 16:00:14 +0400
commit1ed39575e245ff3d56a1132d43b90684857e0191 (patch)
treeee9ef5ceadc633d0102b23d6441255b99fa0f069
parent3273456e1792d6776c6ef747b52c3275d921db32 (diff)
downloadrequests-cache-1ed39575e245ff3d56a1132d43b90684857e0191.tar.gz
Bump version and add info to changelogv0.1.3
-rw-r--r--docs/changelog.rst52
-rw-r--r--requests_cache/__init__.py2
-rw-r--r--setup.py2
3 files changed, 32 insertions, 24 deletions
diff --git a/docs/changelog.rst b/docs/changelog.rst
index b33a6f6..71dc93b 100644
--- a/docs/changelog.rst
+++ b/docs/changelog.rst
@@ -1,23 +1,31 @@
-Changelog
----------
-
-0.1.2 (2012-05-02)
-+++++++++++++++++++
-
-* Reduce number of ``sqlite`` database write operations
-* ``fast_save`` option for ``sqlite`` backend
-
-
-0.1.1 (2012-04-11)
-+++++++++++++++++++
-
-* Fix: restore responses from response.history
-* Internal refactoring (``MemoryCache`` -> ``BaseCache``, ``reduce_response``
- and ``restore_response`` moved to ``BaseCache``)
-* ``connection`` option for ``MongoCache``
-
-
-0.1.0 (2012-04-10)
-+++++++++++++++++++
-
+Changelog
+---------
+
+0.1.3 (2012-05-04)
++++++++++++++++++++
+
+* Thread safety for default ``sqlite`` backend
+* Take into account the POST parameters when cache is configured
+ with 'POST' in ``allowable_methods``
+
+
+0.1.2 (2012-05-02)
++++++++++++++++++++
+
+* Reduce number of ``sqlite`` database write operations
+* ``fast_save`` option for ``sqlite`` backend
+
+
+0.1.1 (2012-04-11)
++++++++++++++++++++
+
+* Fix: restore responses from response.history
+* Internal refactoring (``MemoryCache`` -> ``BaseCache``, ``reduce_response``
+ and ``restore_response`` moved to ``BaseCache``)
+* ``connection`` option for ``MongoCache``
+
+
+0.1.0 (2012-04-10)
++++++++++++++++++++
+
* initial PyPI release \ No newline at end of file
diff --git a/requests_cache/__init__.py b/requests_cache/__init__.py
index 15eb971..2e7675b 100644
--- a/requests_cache/__init__.py
+++ b/requests_cache/__init__.py
@@ -23,7 +23,7 @@
:license: BSD, see LICENSE for more details.
"""
__docformat__ = 'restructuredtext'
-__version__ = '0.1.2'
+__version__ = '0.1.3'
from requests_cache.core import(
configure, enabled, disabled, has_url, get_cache,
diff --git a/setup.py b/setup.py
index 9aa9bb2..c272d49 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ if sys.argv[-1] == 'test':
setup(
name='requests-cache',
packages=['requests_cache', 'requests_cache.backends'],
- version='0.1.2',
+ version='0.1.3',
description='Persistent cache for requests library',
author='Roman Haritonov',
author_email='reclosedev@gmail.com',