summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook.git@proton.me>2022-10-08 14:19:31 -0500
committerJordan Cook <jordan.cook.git@proton.me>2022-10-08 14:20:30 -0500
commit170a627e086baca8d4d3fd4c6cfa960123311b5b (patch)
tree80ee6ab6e72a15477d1abb9fe9d3d521f7cb5c7d
parent4de9929017c0b1373d489eb4d1af86a38829893b (diff)
downloadrequests-cache-170a627e086baca8d4d3fd4c6cfa960123311b5b.tar.gz
Fix potential `AttributeError` due to undetected imports when requests-cache is bundled in a PyInstaller package
-rw-r--r--HISTORY.md1
-rw-r--r--pyproject.toml2
-rw-r--r--requests_cache/__init__.py2
-rw-r--r--requests_cache/_utils.py3
4 files changed, 6 insertions, 2 deletions
diff --git a/HISTORY.md b/HISTORY.md
index 23e817f..be41a26 100644
--- a/HISTORY.md
+++ b/HISTORY.md
@@ -1,6 +1,7 @@
# History
## 0.9.7 (Unreleased)
+* Fix potential `AttributeError` due to undetected imports when requests-cache is bundled in a PyInstaller package
* Update to cattrs 22.2
## 0.9.6 (2022-08-24)
diff --git a/pyproject.toml b/pyproject.toml
index 9350639..6175c1d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "requests-cache"
-version = "0.9.6"
+version = "0.9.7"
description = "A transparent persistent cache for the requests library"
authors = ["Roman Haritonov", "Jordan Cook"]
license = "BSD-2-Clause"
diff --git a/requests_cache/__init__.py b/requests_cache/__init__.py
index b0c7bde..546b903 100644
--- a/requests_cache/__init__.py
+++ b/requests_cache/__init__.py
@@ -2,7 +2,7 @@
# Version is defined in pyproject.toml.
# It's copied here to make it easier for client code to check the installed version.
-__version__ = '0.9.6'
+__version__ = '0.9.7'
from .backends import *
from .cache_control import *
diff --git a/requests_cache/_utils.py b/requests_cache/_utils.py
index b3dfaee..63212c0 100644
--- a/requests_cache/_utils.py
+++ b/requests_cache/_utils.py
@@ -38,6 +38,9 @@ def get_placeholder_class(original_exception: Exception = None):
def dumps(self, *args, **kwargs):
_log_error()
+ def loads(self, *args, **kwargs):
+ _log_error()
+
return Placeholder