summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Haritonov <reclosedev@gmail.com>2014-10-13 22:11:36 +0400
committerRoman Haritonov <reclosedev@gmail.com>2014-10-13 22:11:36 +0400
commita1b5e65ccd715f1e8434f18f27913715340d6aaf (patch)
tree79d56f672bc994732b90d216cc01ab5ef6c57789
parentbdd43c43351a3d1cb16483c3a4fb5589b33a2b03 (diff)
downloadrequests-cache-a1b5e65ccd715f1e8434f18f27913715340d6aaf.tar.gz
Bump version 0.4.6v0.4.6
-rw-r--r--HISTORY.rst33
-rw-r--r--requests_cache/__init__.py4
-rw-r--r--setup.py2
3 files changed, 23 insertions, 16 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index 399972b..d86f7de 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -3,6 +3,13 @@
History
-------
+0.4.6 (2014-10-13)
+++++++++++++++++++
+
+* Monkey patch now uses class instead lambda (compatibility with rauth)
+* Normalize (sort) parameters passed as builtin dict
+
+
0.4.5 (2014-08-22)
++++++++++++++++++
@@ -10,60 +17,60 @@ History
0.4.4 (2013-10-31)
-+++++++++++++++++++
+++++++++++++++++++
* Check for backend availability in install_cache(), not at the first request
* Default storage fallbacks to memory if ``sqlite`` is not available
0.4.3 (2013-09-12)
-+++++++++++++++++++
+++++++++++++++++++
* Fix ``response.from_cache`` not set in hooks
0.4.2 (2013-08-25)
-+++++++++++++++++++
+++++++++++++++++++
* Fix ``UnpickleableError`` for gzip responses
0.4.1 (2013-08-19)
-+++++++++++++++++++
+++++++++++++++++++
* ``requests_cache.enabled()`` context manager
* Compatibility with Requests 1.2.3 cookies handling
0.4.0 (2013-04-25)
-+++++++++++++++++++
+++++++++++++++++++
* Redis backend. Thanks to @michaelbeaumont
* Fix for changes in Requests 1.2.0 hooks dispatching
0.3.0 (2013-02-24)
-+++++++++++++++++++
+++++++++++++++++++
* Support for ``Requests`` 1.x.x
* ``CachedSession``
* Many backward incompatible changes
0.2.1 (2013-01-13)
-+++++++++++++++++++
+++++++++++++++++++
* Fix broken PyPi package
0.2.0 (2013-01-12)
-+++++++++++++++++++
+++++++++++++++++++
* Last backward compatible version for ``Requests`` 0.14.2
0.1.3 (2012-05-04)
-+++++++++++++++++++
+++++++++++++++++++
* Thread safety for default ``sqlite`` backend
* Take into account the POST parameters when cache is configured
@@ -71,14 +78,14 @@ History
0.1.2 (2012-05-02)
-+++++++++++++++++++
+++++++++++++++++++
* Reduce number of ``sqlite`` database write operations
* ``fast_save`` option for ``sqlite`` backend
0.1.1 (2012-04-11)
-+++++++++++++++++++
+++++++++++++++++++
* Fix: restore responses from response.history
* Internal refactoring (``MemoryCache`` -> ``BaseCache``, ``reduce_response``
@@ -87,6 +94,6 @@ History
0.1.0 (2012-04-10)
-+++++++++++++++++++
+++++++++++++++++++
-* initial PyPI release \ No newline at end of file
+* initial PyPI release
diff --git a/requests_cache/__init__.py b/requests_cache/__init__.py
index 5f5bd33..45ec26f 100644
--- a/requests_cache/__init__.py
+++ b/requests_cache/__init__.py
@@ -23,9 +23,9 @@
:license: BSD, see LICENSE for more details.
"""
__docformat__ = 'restructuredtext'
-__version__ = '0.4.5'
+__version__ = '0.4.6'
from .core import(
CachedSession, install_cache, uninstall_cache,
disabled, enabled, get_cache, clear, configure
-) \ No newline at end of file
+)
diff --git a/setup.py b/setup.py
index 4574f43..54b33c6 100644
--- a/setup.py
+++ b/setup.py
@@ -20,7 +20,7 @@ setup(
packages=['requests_cache',
'requests_cache.backends',
'requests_cache.backends.storage'],
- version='0.4.5',
+ version='0.4.6',
description='Persistent cache for requests library',
author='Roman Haritonov',
author_email='reclosedev@gmail.com',