summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f6120c7..6e9c219 100644
--- a/setup.py
+++ b/setup.py
@@ -29,12 +29,17 @@ CLASSIFIERS = [
'Topic :: Utilities',
]
+with open('README.rst') as file_readme:
+ readme = file_readme.read()
+
+with open('HISTORY.rst') as file_history:
+ history = file_history.read()
+
settings.update(
name='retrying',
version='1.2.3-dev',
description='Retrying',
- long_description=open('README.rst').read() + '\n\n' +
- open('HISTORY.rst').read(),
+ long_description=readme + '\n\n' + history,
author='Ray Holder',
license='Apache 2.0',
url='https://github.com/rholder/retrying',