summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSelwin Ong <selwin.ong@gmail.com>2017-09-08 16:13:53 +0700
committerGitHub <noreply@github.com>2017-09-08 16:13:53 +0700
commit009c478822251771202009de7c15d2d6037d5010 (patch)
tree9dc1b9edfb1fd9e2143113d37a69387f87cae67a
parent906440e83f1d1ae7b8b19c6343157cf5160def17 (diff)
parent4447aa1a8294d60ab4c156add50087702cbc2370 (diff)
downloadrq-009c478822251771202009de7c15d2d6037d5010.tar.gz
Merge pull request #868 from theodesp/issue-867
Fixed [Issue 867] Simplified code in setup.py
-rw-r--r--setup.py25
1 files changed, 13 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 7b86294..f22355a 100644
--- a/setup.py
+++ b/setup.py
@@ -2,18 +2,19 @@
rq is a simple, lightweight, library for creating background jobs, and
processing them.
"""
-import sys
import os
from setuptools import setup, find_packages
def get_version():
basedir = os.path.dirname(__file__)
- with open(os.path.join(basedir, 'rq/version.py')) as f:
- locals = {}
- exec(f.read(), locals)
- return locals['VERSION']
- raise RuntimeError('No version info found.')
+ try:
+ with open(os.path.join(basedir, 'rq/version.py')) as f:
+ locals = {}
+ exec(f.read(), locals)
+ return locals['VERSION']
+ except FileNotFoundError:
+ raise RuntimeError('No version info found.')
setup(
@@ -47,13 +48,13 @@ setup(
},
classifiers=[
# As from http://pypi.python.org/pypi?%3Aaction=list_classifiers
- #'Development Status :: 1 - Planning',
- #'Development Status :: 2 - Pre-Alpha',
- #'Development Status :: 3 - Alpha',
- #'Development Status :: 4 - Beta',
+ # 'Development Status :: 1 - Planning',
+ # 'Development Status :: 2 - Pre-Alpha',
+ # 'Development Status :: 3 - Alpha',
+ # 'Development Status :: 4 - Beta',
'Development Status :: 5 - Production/Stable',
- #'Development Status :: 6 - Mature',
- #'Development Status :: 7 - Inactive',
+ # 'Development Status :: 6 - Mature',
+ # 'Development Status :: 7 - Inactive',
'Intended Audience :: Developers',
'Intended Audience :: End Users/Desktop',
'Intended Audience :: Information Technology',