summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2020-11-19 23:40:38 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2021-01-10 11:26:14 +0100
commitb81e3171e9f870892e6b8a894db6d00ecd93f544 (patch)
treea7fdec1c434559c63e31b0e732a8fc8ac0efbb7c
parent06ec1ea1cc7be6034144bd06f07c35eb9d1b4953 (diff)
downloadrsa-git-b81e3171e9f870892e6b8a894db6d00ecd93f544.tar.gz
Declare support for and test Python 3.9
-rw-r--r--.travis.yml1
-rw-r--r--CHANGELOG.md1
-rwxr-xr-xsetup.py1
-rw-r--r--tox.ini2
4 files changed, 4 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 0fed68b..ff7329c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,6 +9,7 @@ python:
- "3.6"
- "3.7"
- "3.8"
+ - "3.9"
matrix:
include:
diff --git a/CHANGELOG.md b/CHANGELOG.md
index fe1ab28..826c3d9 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -9,6 +9,7 @@
[#164](https://github.com/sybrenstuvel/python-rsa/issues/164))
- Reuse of blinding factors to speed up blinding operations.
Fixes [#162](https://github.com/sybrenstuvel/python-rsa/issues/162).
+- Declare & test support for Python 3.9
## Version 4.4 & 4.6 - released 2020-06-12
diff --git a/setup.py b/setup.py
index bdc552a..5f15130 100755
--- a/setup.py
+++ b/setup.py
@@ -49,6 +49,7 @@ if __name__ == '__main__':
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Security :: Cryptography',
diff --git a/tox.ini b/tox.ini
index 0552a17..1a033ae 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
# Environment changes have to be manually synced with '.travis.yml'.
-envlist = py35,py36,p37,p38
+envlist = py35,py36,p37,p38,p39
[pytest]
addopts = -v --cov rsa --cov-report term-missing