summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2020-06-12 19:31:22 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2020-06-12 19:31:22 +0200
commit27e25af65ffe633e51246c35e1f87e6bcfc22c57 (patch)
tree4533c6259172103147b40728e92ab68ee8292a75
parent3283b1284475cf6c79a7329aee8bd7443cc72672 (diff)
downloadrsa-git-27e25af65ffe633e51246c35e1f87e6bcfc22c57.tar.gz
Drop support for Python 3.4
Tests on Travis-CI fail on Python 3.4. Since this is an intermediary release to fix some issues for Python 2.7, I keep Python 3.4 as unsupported.
-rw-r--r--.travis.yml1
-rw-r--r--CHANGELOG.txt2
-rwxr-xr-xsetup.py3
-rw-r--r--tox.ini2
4 files changed, 3 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 9b4da02..3d1dded 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,7 +9,6 @@ cache: pip
python:
- "2.7"
- - "3.4"
- "3.5"
- "3.6"
- "3.7-dev"
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 96a380d..b49f25d 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -6,7 +6,7 @@ Version 4.3 - released 2020-06-12
Version 4.3 is almost a re-tagged release of version 4.0. It is the last to
support Python 2.7. This is now made explicit in the `python_requires` argument
-in `setup.py`.
+in `setup.py`. Python 3.4 is not supported by this release.
Two security fixes have also been backported, so 4.3 = 4.0 + these two fixes.
diff --git a/setup.py b/setup.py
index d0df098..32edff6 100755
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,6 @@ if __name__ == '__main__':
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
@@ -51,7 +50,7 @@ if __name__ == '__main__':
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Security :: Cryptography',
],
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, <4',
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, <4',
install_requires=[
'pyasn1 >= 0.1.3',
],
diff --git a/tox.ini b/tox.ini
index a3109e4..e3c4335 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
# Environment changes have to be manually synced with '.travis.yml'.
-envlist = py27,py34,py35,py36,p37,pypy
+envlist = py27,py35,py36,p37,pypy
[pytest]
addopts = -v --cov rsa --cov-report term-missing