summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2020-06-12 19:01:00 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2020-06-12 19:01:00 +0200
commita1f221b1dfd4ba9ed64ed42590c8777fd73cec31 (patch)
treebcc1964f0dca75d971ca83674bac8f05636b5c74
parent368a31f431f24843189b5d4da6b8530fa8bd47d8 (diff)
downloadrsa-git-a1f221b1dfd4ba9ed64ed42590c8777fd73cec31.tar.gz
Add `python_requires` stanza to setup.py
This is part of a fix for https://github.com/sybrenstuvel/python-rsa/issues/152
-rw-r--r--CHANGELOG.txt10
-rw-r--r--README.md9
-rwxr-xr-xsetup.py1
3 files changed, 20 insertions, 0 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index f8ed650..3a12e64 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,6 +1,16 @@
Python-RSA changelog
========================================
+Version 4.3 - released 2020-06-12
+----------------------------------------
+
+Version 4.3 is a re-tagged release of version 4.0. It is the last to support
+Python 2.7. This is now made explicit in the `python_requires` argument in
+`setup.py`.
+
+There are no functional differences.
+
+
Version 4.0 - released 2018-09-16
----------------------------------------
diff --git a/README.md b/README.md
index c5e0f2d..b7df4fb 100644
--- a/README.md
+++ b/README.md
@@ -23,6 +23,15 @@ or download it from the [Python Package Index](https://pypi.org/project/rsa/).
The source code is maintained at [GitHub](https://github.com/sybrenstuvel/python-rsa/) and is
licensed under the [Apache License, version 2.0](https://www.apache.org/licenses/LICENSE-2.0)
+Changes in 4.1-4.4
+------------------
+
+Version 4.1 dropped support for Python 2.7, and soon after that version 4.2 was released. Neither of the two made it explicit in `setup.cfg` that Python 3.5 or newer is required. This caused issues on Python 2.7, as Pip happily upgraded to the new version.
+
+Version 4.3 is a re-tagged release of version 4.0. It is the last to support Python 2.7.
+
+Version 4.4 will be a re-tagged release of version 4.2, and explicitly require Python 3.5 or newer.
+
Major changes in 4.0
--------------------
diff --git a/setup.py b/setup.py
index 18f339e..71bf99a 100755
--- a/setup.py
+++ b/setup.py
@@ -51,6 +51,7 @@ if __name__ == '__main__':
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Security :: Cryptography',
],
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, <4',
install_requires=[
'pyasn1 >= 0.1.3',
],