summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..f704dd1
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+from setuptools import setup
+
+setup(name='rsa',
+ version='1.1',
+ description='Pure-Python RSA implementation',
+ author=u'Sybren Stüvel'.encode('utf-8'),
+ author_email='sybren@stuvel.eu',
+ maintainer=u'Sybren Stüvel'.encode('utf-8'),
+ maintainer_email='sybren@stuvel.eu',
+ url='http://www.stuvel.eu/rsa',
+ packages=['rsa'],
+ license='GPL',
+ classifiers=[
+ 'Development Status :: 5 - Beta',
+ 'Intended Audience :: End Users/Desktop',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Multimedia :: Graphics :: Capture :: Digital Camera',
+ 'Topic :: Artistic Software',
+ 'Natural Language :: English',
+ ],
+)