summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile3
-rw-r--r--example-rpm/python-rtslib.spec.tmpl5
2 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 987d4fd..bfc9010 100644
--- a/Makefile
+++ b/Makefile
@@ -101,7 +101,8 @@ build/release-stamp:
@cd build; tar -c --owner=0 --group=0 --numeric-owner \
--format=gnu -b20 --quoting-style=escape \
-f ../dist/${PKGNAME}-${VERSION}.tar \
- $$(find ${PKGNAME}-${VERSION} -type f | sort)
+ $$(find ${PKGNAME}-${VERSION} -type f | sort) \
+ $$(find ${PKGNAME}-${VERSION} -type l | sort)
@gzip -6 -n dist/${PKGNAME}-${VERSION}.tar
@echo "Generated release tarball:"
@echo " $$(ls dist/${PKGNAME}-${VERSION}.tar.gz)"
diff --git a/example-rpm/python-rtslib.spec.tmpl b/example-rpm/python-rtslib.spec.tmpl
index ae566b5..2191b7a 100644
--- a/example-rpm/python-rtslib.spec.tmpl
+++ b/example-rpm/python-rtslib.spec.tmpl
@@ -1,4 +1,4 @@
-%define oname rtslib
+%define oname rtslib-fb
Name: python-rtslib
License: Apache License 2.0
@@ -22,7 +22,7 @@ API for RisingTide Systems generic SCSI target.
%build
%{__python} setup.py build
mkdir -p doc
-epydoc --no-sourcecode --html -n %{oname} --exclude configobj %{oname}/*.py
+epydoc --no-sourcecode --html -n %{oname} --exclude configobj rtslib_fb/*.py
mv html doc/
%install
@@ -37,6 +37,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%{python_sitelib}
+%{_bindir}/targetctl
/usr/share/doc/python-rtslib-doc-%{version}
%doc COPYING README.md