summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2016-01-30 13:11:46 +0100
committerAnthon van der Neut <anthon@mnt.org>2016-01-30 13:11:46 +0100
commit1f57915677480570ea066629b8ffb89689474306 (patch)
tree11de18e54af5c395199ff5f2ab91bb958d525eb7
parentd7f48bad6ad594d3ba899edf8b1096a18b6860ae (diff)
downloadruamel.yaml-1f57915677480570ea066629b8ffb89689474306.tar.gz
getpip for 2.6
-rw-r--r--.appveyor.yaml40
-rw-r--r--appveyor.yml28
2 files changed, 40 insertions, 28 deletions
diff --git a/.appveyor.yaml b/.appveyor.yaml
new file mode 100644
index 0000000..e900c7b
--- /dev/null
+++ b/.appveyor.yaml
@@ -0,0 +1,40 @@
+environment:
+
+ matrix:
+ - PYTHON: C:\Python266
+# - PYTHON: C:\Python27
+# - PYTHON: C:\Python33
+# - PYTHON: C:\Python34
+# - PYTHON: C:\Python35
+ - PYTHON: C:\Python266-x64
+# - PYTHON: C:\Python27-x64
+# - PYTHON: C:\Python33-x64
+# DISTUTILS_USE_SDK: '1'
+# - PYTHON: 'C:\Python34-x64'
+# DISTUTILS_USE_SDK: '1'
+# - PYTHON: 'C:\Python35-x64'
+
+install:
+ - >
+ /opt/python/2.6.6/bin/python -c "import sys, os;
+ os.system('%s -c \\"import urllib2; open(\\'c:\\\\get-pip.py\\', \\'w\\').
+ write(urllib2.urlopen(\\'https://bootstrap.pypa.io/get-pip.py\\').read())\\"'
+ % sys.executable)
+ if sys.version_info < (2, 7) else True"
+ - >
+ /opt/python/2.6.6/bin/python -c "import sys, os;
+ os.system('%s c:\\get-pip.py' % sys.executable)
+ if sys.version_info < (2, 7) else True"
+ - %PYTHON%\python.exe -m pip install wheel
+
+build: off
+
+test_script:
+ - echo Skipped for now
+
+after_test:
+ - %PYTHON%\python.exe setup.py bdist_wheel
+
+artifacts:
+ # bdist_wheel puts your built wheel in the dist directory
+ - path: dist\*
diff --git a/appveyor.yml b/appveyor.yml
deleted file mode 100644
index ecc2f59..0000000
--- a/appveyor.yml
+++ /dev/null
@@ -1,28 +0,0 @@
-environment:
-
- matrix:
- - PYTHON: 'C:\Python27'
- - PYTHON: 'C:\Python33'
- - PYTHON: 'C:\Python34'
- - PYTHON: 'C:\Python35'
- - PYTHON: 'C:\Python27-x64'
- - PYTHON: 'C:\Python33-x64'
- DISTUTILS_USE_SDK: '1'
- - PYTHON: 'C:\Python34-x64'
- DISTUTILS_USE_SDK: '1'
- - PYTHON: 'C:\Python35-x64'
-
-install:
- - '%PYTHON%\python.exe -m pip install wheel'
-
-build: off
-
-test_script:
- - echo Skipped for now
-
-after_test:
- - '%PYTHON%\python.exe setup.py bdist_wheel'
-
-artifacts:
- # bdist_wheel puts your built wheel in the dist directory
- - path: dist\*