summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2016-01-30 11:12:08 +0100
committerAnthon van der Neut <anthon@mnt.org>2016-01-30 11:12:08 +0100
commitd7f48bad6ad594d3ba899edf8b1096a18b6860ae (patch)
tree4a9b4e39f255e16e7bf47d4a21d3f7b05cfb1142
parent98daee12747b26db6122c22f54cee13148aebe62 (diff)
downloadruamel.yaml-d7f48bad6ad594d3ba899edf8b1096a18b6860ae.tar.gz
- initial test for appveyor builds of windows wheels
-rw-r--r--.hgignore12
-rw-r--r--__init__.py2
-rw-r--r--appveyor.yml28
3 files changed, 38 insertions, 4 deletions
diff --git a/.hgignore b/.hgignore
index 27b72c9..0426bfb 100644
--- a/.hgignore
+++ b/.hgignore
@@ -1,20 +1,26 @@
syntax: glob
+# python derivatives
*.pyc
+*.pyo
+*$py.class
+# backup files
*~
*.bak
*.o
*.orig
+.ruamel
+# pip / setup related
dist
-venv
build
*.egg-info
+# tox related
.tox
.cache
+
_yaml.so
README.pdf
-.ruamel
-*$py.class
+venv
convert
cmd
TODO.rst
diff --git a/__init__.py b/__init__.py
index da02b6f..123ebbe 100644
--- a/__init__.py
+++ b/__init__.py
@@ -9,7 +9,7 @@ from __future__ import absolute_import
_package_data = dict(
full_package_name="ruamel.yaml",
- version_info=(0, 10, 17),
+ version_info=(0, 10, 18),
author="Anthon van der Neut",
author_email="a.van.der.neut@ruamel.eu",
description="ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order", # NOQA
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 0000000..ecc2f59
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,28 @@
+environment:
+
+ matrix:
+ - PYTHON: 'C:\Python27'
+ - PYTHON: 'C:\Python33'
+ - PYTHON: 'C:\Python34'
+ - PYTHON: 'C:\Python35'
+ - PYTHON: 'C:\Python27-x64'
+ - PYTHON: 'C:\Python33-x64'
+ DISTUTILS_USE_SDK: '1'
+ - PYTHON: 'C:\Python34-x64'
+ DISTUTILS_USE_SDK: '1'
+ - PYTHON: 'C:\Python35-x64'
+
+install:
+ - '%PYTHON%\python.exe -m pip install wheel'
+
+build: off
+
+test_script:
+ - echo Skipped for now
+
+after_test:
+ - '%PYTHON%\python.exe setup.py bdist_wheel'
+
+artifacts:
+ # bdist_wheel puts your built wheel in the dist directory
+ - path: dist\*