summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2016-02-29 17:42:51 +0100
committerAnthon van der Neut <anthon@mnt.org>2016-02-29 17:42:51 +0100
commit5139e5f0cd2f28dc0737ab88c60dd39f18c48d86 (patch)
tree805d8c8a822009de285dbefae7d4723d946154cd
parent0e9b775bedc021ebbf0b690da83c3172fe55df5a (diff)
downloadruamel.yaml-5139e5f0cd2f28dc0737ab88c60dd39f18c48d86.tar.gz
trigger read-the-docs0.11.6
-rw-r--r--README.rst3
-rw-r--r--__init__.py3
-rw-r--r--setup.py4
3 files changed, 9 insertions, 1 deletions
diff --git a/README.rst b/README.rst
index dcee736..bcdd7d2 100644
--- a/README.rst
+++ b/README.rst
@@ -10,6 +10,9 @@ ruamel.yaml
* `Examples <http://yaml.readthedocs.org/en/latest/example.html>`_
* `Differences with PyYAML <http://yaml.readthedocs.org/en/latest/pyyaml.html>`_
+.. image:: https://readthedocs.org/projects/yaml/badge/?version=stable
+ :target: https://yaml.readthedocs.org/en/stable
+
ChangeLog
=========
diff --git a/__init__.py b/__init__.py
index f20d0a3..00b96e8 100644
--- a/__init__.py
+++ b/__init__.py
@@ -9,7 +9,7 @@ from __future__ import absolute_import
_package_data = dict(
full_package_name="ruamel.yaml",
- version_info=(0, 11, 5),
+ version_info=(0, 11, 6),
author="Anthon van der Neut",
author_email="a.van.der.neut@ruamel.eu",
description="ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order", # NOQA
@@ -41,6 +41,7 @@ _package_data = dict(
"Topic :: Text Processing :: Markup"
],
windows_wheels=True,
+ read_the_docs = 'yaml',
)
diff --git a/setup.py b/setup.py
index 3707cf4..0f81d70 100644
--- a/setup.py
+++ b/setup.py
@@ -234,7 +234,11 @@ class NameSpacePackager(object):
self._pkg = [None, None] # required and pre-installable packages
if sys.argv[0] == 'setup.py' and sys.argv[1] == 'install' and \
'--single-version-externally-managed' not in sys.argv:
+ if os.environ.get('READTHEDOCS', None) == 'True':
+ os.system('pip install .')
+ sys.exit(0)
print('error: you have to install with "pip install ."')
+ o
sys.exit(1)
# If you only support an extension module on Linux, Windows thinks it
# is pure. That way you would get pure python .whl files that take