summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2017-07-23 20:43:33 +0200
committerAnthon van der Neut <anthon@mnt.org>2017-07-23 20:43:33 +0200
commite7dc575883af0b0a2ad6d7f3cd220611b94c7790 (patch)
tree581b8460354e2755216c4910b42e8c05cf9092d8
parent054aa037bb2f524a157f4dc3795019c9d57f462f (diff)
downloadruamel.yaml-e7dc575883af0b0a2ad6d7f3cd220611b94c7790.tar.gz
appveyor changes
-rw-r--r--.appveyor.yaml14
-rw-r--r--README.rst3
-rw-r--r--setup.py4
3 files changed, 12 insertions, 9 deletions
diff --git a/.appveyor.yaml b/.appveyor.yaml
index eecbfd8..0aee751 100644
--- a/.appveyor.yaml
+++ b/.appveyor.yaml
@@ -4,12 +4,12 @@ environment:
matrix:
- PYTHON: C:\Python27
- PYTHON: C:\Python27-x64
- # - PYTHON: C:\Python33
- # - PYTHON: C:\Python33-x64
- # DISTUTILS_USE_SDK: '1'
- # - PYTHON: C:\Python34
- # - PYTHON: C:\Python34-x64
- # DISTUTILS_USE_SDK: '1'
+ - PYTHON: C:\Python33
+ - PYTHON: C:\Python33-x64
+ DISTUTILS_USE_SDK: '1'
+ - PYTHON: C:\Python34
+ - PYTHON: C:\Python34-x64
+ DISTUTILS_USE_SDK: '1'
- PYTHON: C:\Python35
- PYTHON: C:\Python35-x64
- PYTHON: C:\Python36
@@ -28,7 +28,7 @@ test_script:
after_test:
- |
- %PYTHON%\python.exe setup.py --verbose bdist_wheel
+ %PYTHON%\python.exe setup.py bdist_wheel
artifacts:
- path: dist\*
diff --git a/README.rst b/README.rst
index e547aa0..cdc1273 100644
--- a/README.rst
+++ b/README.rst
@@ -35,6 +35,9 @@ ChangeLog
.. should insert NEXT: at the beginning of line for next key
+NEXT:
+ - wheels for windows including C extensions
+
0.15.19 (2017-07-13):
- added object constructor for rt, decorator ``yaml_object`` to replace YAMLObject.
- fix for problem using load_all with Path() instance
diff --git a/setup.py b/setup.py
index a6883cd..1d62689 100644
--- a/setup.py
+++ b/setup.py
@@ -712,8 +712,8 @@ class NameSpacePackager(object):
return None
if platform.python_implementation() == 'Jython':
return None
- # if sys.platform == "win32" and not self._pkg_data.get('win32bin'):
- # return None
+ if sys.platform == "win32" and not self._pkg_data.get('win32bin'):
+ return None
# if sys.platform == "win32":
# if os.getenv("RUAMEL_FORCE_EXT_BUILD") is None:
# return None