summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2020-09-03 20:40:51 +0200
committerAnthon van der Neut <anthon@mnt.org>2020-09-03 20:40:51 +0200
commit53a39bcc144e46221caee39f49cd753f956b0657 (patch)
treeb45181ad4864f66157be031648da1bfa2e4baab5
parentb3acb5b97d8cd60064c6bfd0d7921e4f96c185c8 (diff)
downloadruamel.yaml-53a39bcc144e46221caee39f49cd753f956b0657.tar.gz
udpate setup.py to workaround issue in setuptools0.16.11
https://github.com/pypa/setuptools/issues/2355#issuecomment-685159580
-rw-r--r--CHANGES4
-rw-r--r--README.rst8
-rw-r--r--__init__.py4
-rw-r--r--_doc/_static/pypi.svg2
-rw-r--r--anchor.py1
-rw-r--r--emitter.py6
-rw-r--r--setup.py8
7 files changed, 19 insertions, 14 deletions
diff --git a/CHANGES b/CHANGES
index a70a8ef..04afa52 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,7 @@
+[0, 16, 11]: 2020-09-03
+ - workaround issue with setuptools 0.50 and importing pip ( fix by jaraco
+ https://github.com/pypa/setuptools/issues/2355#issuecomment-685159580 )
+
[0, 16, 10]: 2020-02-12
- (auto) updated image references in README to sourceforge
diff --git a/README.rst b/README.rst
index 2a99cb9..0ff1188 100644
--- a/README.rst
+++ b/README.rst
@@ -4,8 +4,8 @@ ruamel.yaml
``ruamel.yaml`` is a YAML 1.2 loader/dumper package for Python.
-:version: 0.16.10
-:updated: 2020-02-12
+:version: 0.16.11
+:updated: 2020-09-03
:documentation: http://yaml.readthedocs.io
:repository: https://bitbucket.org/ruamel/yaml
:pypi: https://pypi.org/project/ruamel.yaml/
@@ -54,6 +54,10 @@ ChangeLog
.. should insert NEXT: at the beginning of line for next key (with empty line)
+0.16.11 (2020-09-03):
+ - workaround issue with setuptools 0.50 and importing pip ( fix by jaraco
+ https://github.com/pypa/setuptools/issues/2355#issuecomment-685159580 )
+
0.16.10 (2020-02-12):
- (auto) updated image references in README to sourceforge
diff --git a/__init__.py b/__init__.py
index 7bc157b..7cb014b 100644
--- a/__init__.py
+++ b/__init__.py
@@ -7,8 +7,8 @@ if False: # MYPY
_package_data = dict(
full_package_name='ruamel.yaml',
- version_info=(0, 16, 10),
- __version__='0.16.10',
+ version_info=(0, 16, 11),
+ __version__='0.16.11',
author='Anthon van der Neut',
author_email='a.van.der.neut@ruamel.eu',
description='ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order', # NOQA
diff --git a/_doc/_static/pypi.svg b/_doc/_static/pypi.svg
index 15d64e3..1bb63c1 100644
--- a/_doc/_static/pypi.svg
+++ b/_doc/_static/pypi.svg
@@ -1 +1 @@
-<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="86" height="20"><linearGradient id="b" x2="0" y2="100%"><stop offset="0" stop-color="#bbb" stop-opacity=".1"/><stop offset="1" stop-opacity=".1"/></linearGradient><clipPath id="a"><rect width="86" height="20" rx="3" fill="#fff"/></clipPath><g clip-path="url(#a)"><path fill="#555" d="M0 0h33v20H0z"/><path fill="#007ec6" d="M33 0h53v20H33z"/><path fill="url(#b)" d="M0 0h86v20H0z"/></g><g fill="#fff" text-anchor="middle" font-family="DejaVu Sans,Verdana,Geneva,sans-serif" font-size="110"> <text x="175" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="230">pypi</text><text x="175" y="140" transform="scale(.1)" textLength="230">pypi</text><text x="585" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="430">0.16.10</text><text x="585" y="140" transform="scale(.1)" textLength="430">0.16.10</text></g> </svg>
+<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="86" height="20"><linearGradient id="b" x2="0" y2="100%"><stop offset="0" stop-color="#bbb" stop-opacity=".1"/><stop offset="1" stop-opacity=".1"/></linearGradient><clipPath id="a"><rect width="86" height="20" rx="3" fill="#fff"/></clipPath><g clip-path="url(#a)"><path fill="#555" d="M0 0h33v20H0z"/><path fill="#007ec6" d="M33 0h53v20H33z"/><path fill="url(#b)" d="M0 0h86v20H0z"/></g><g fill="#fff" text-anchor="middle" font-family="DejaVu Sans,Verdana,Geneva,sans-serif" font-size="110"> <text x="175" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="230">pypi</text><text x="175" y="140" transform="scale(.1)" textLength="230">pypi</text><text x="585" y="150" fill="#010101" fill-opacity=".3" transform="scale(.1)" textLength="430">0.16.11</text><text x="585" y="140" transform="scale(.1)" textLength="430">0.16.11</text></g> </svg>
diff --git a/anchor.py b/anchor.py
index aa649f5..d702126 100644
--- a/anchor.py
+++ b/anchor.py
@@ -1,4 +1,3 @@
-
if False: # MYPY
from typing import Any, Dict, Optional, List, Union, Optional, Iterator # NOQA
diff --git a/emitter.py b/emitter.py
index 41dc3e8..99e8abe 100644
--- a/emitter.py
+++ b/emitter.py
@@ -169,14 +169,14 @@ class Emitter(object):
self.prefixed_colon = self.colon if prefix_colon is None else prefix_colon + self.colon
# single entry mappings in flow sequence
self.brace_single_entry_mapping_in_flow_sequence = (
- brace_single_entry_mapping_in_flow_sequence
- ) # NOQA
+ brace_single_entry_mapping_in_flow_sequence # NOQA
+ )
# Formatting details.
self.canonical = canonical
self.allow_unicode = allow_unicode
# set to False to get "\Uxxxxxxxx" for non-basic unicode like emojis
- self.unicode_supplementary = sys.maxunicode > 0xffff
+ self.unicode_supplementary = sys.maxunicode > 0xFFFF
self.sequence_dash_offset = block_seq_indent if block_seq_indent else 0
self.top_level_colon_align = top_level_colon_align
self.best_sequence_indent = 2
diff --git a/setup.py b/setup.py
index f22dceb..40aba3a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
# # header
# coding: utf-8
-# dd: 20200125
+# dd: 20200903
from __future__ import print_function, absolute_import, division, unicode_literals
@@ -446,10 +446,8 @@ class NameSpacePackager(object):
sys.exit(1)
def check(self):
- try:
- from pip.exceptions import InstallationError
- except ImportError:
- return
+ # https://github.com/pypa/setuptools/issues/2355#issuecomment-685159580
+ InstallationError = Exception
# arg is either develop (pip install -e) or install
if self.command not in ['install', 'develop']:
return