summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2017-07-23 18:53:59 +0200
committerAnthon van der Neut <anthon@mnt.org>2017-07-23 18:53:59 +0200
commitf676bf0e282693a373388d2859f048f0af9ce1c4 (patch)
treec9fd857c9c2c2cf9c72e17b5be3fb9c5e9239d91
parent8a06624a59b0efdfa1995ed03be841d1f2b80ae4 (diff)
downloadruamel.yaml-f676bf0e282693a373388d2859f048f0af9ce1c4.tar.gz
appveyor changes
-rw-r--r--.appveyor.yaml2
-rw-r--r--setup.py10
2 files changed, 6 insertions, 6 deletions
diff --git a/.appveyor.yaml b/.appveyor.yaml
index f11d6f7..eecbfd8 100644
--- a/.appveyor.yaml
+++ b/.appveyor.yaml
@@ -17,7 +17,7 @@ environment:
install:
- |
- %PYTHON%\python.exe -m pip install --upgrade -q pip wheel
+ %PYTHON%\python.exe -m pip install --upgrade -q pip wheel setuptools
%PYTHON%\python.exe -m pip list --format columns
# only used when compiling (for Python with C extensions this is done in the after_test)
diff --git a/setup.py b/setup.py
index e540f93..a6883cd 100644
--- a/setup.py
+++ b/setup.py
@@ -712,11 +712,11 @@ class NameSpacePackager(object):
return None
if platform.python_implementation() == 'Jython':
return None
- if sys.platform == "win32" and not self._pkg_data.get('win32bin'):
- return None
- if sys.platform == "win32":
- if os.getenv("RUAMEL_FORCE_EXT_BUILD") is None:
- return None
+ # if sys.platform == "win32" and not self._pkg_data.get('win32bin'):
+ # return None
+ # if sys.platform == "win32":
+ # if os.getenv("RUAMEL_FORCE_EXT_BUILD") is None:
+ # return None
try:
plat = sys.argv.index('--plat-name')
if 'win' in sys.argv[plat + 1]: