summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2017-06-25 08:22:06 +0200
committerAnthon van der Neut <anthon@mnt.org>2017-06-25 08:22:06 +0200
commitea2b25165c2b2b23bf7f3a11704f9d273848f87e (patch)
treedd9ecde44c975742b544cf3e8ddbeb9d8dbc38c3
parentdf1814c4ec4bb94f5bffcfb1e8a258d763c1349e (diff)
downloadruamel.yaml-ea2b25165c2b2b23bf7f3a11704f9d273848f87e.tar.gz
change ModuleNotFoundError to ImportError0.15.14
fixes issue #133 Please close this issue if you can confirm it solves the reported problem
-rw-r--r--CHANGES3
-rw-r--r--README.rst5
-rw-r--r--__init__.py4
-rw-r--r--setup.py2
4 files changed, 11 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index 0e092ad..92d2af4 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,6 @@
+[0, 15, 14]: 2017-06-25
+ - setup.py: change ModuleNotFoundError to ImportError (reported and fix by Asley Drake)
+
[0, 15, 13]: 2017-06-24
- suppress duplicate key warning on mappings with merge keys (reported by
Cameron Sweeney)
diff --git a/README.rst b/README.rst
index e5beec0..e53c697 100644
--- a/README.rst
+++ b/README.rst
@@ -32,6 +32,11 @@ ChangeLog
.. should insert NEXT: at the beginning of line for next key
+0.15.14 (2017-06-25):
+ - fix for issue 133, in setup.py: change ModuleNotFoundError to
+ ImportError (reported and fix by
+ `Asley Drake <https://github.com/aldraco>`_)
+
0.15.13 (2017-06-24):
- suppress duplicate key warning on mappings with merge keys (reported by
Cameron Sweeney)
diff --git a/__init__.py b/__init__.py
index a592d14..7543ce5 100644
--- a/__init__.py
+++ b/__init__.py
@@ -7,8 +7,8 @@ if False: # MYPY
_package_data = dict(
full_package_name='ruamel.yaml',
- version_info=(0, 15, 13),
- __version__='0.15.13',
+ version_info=(0, 15, 14),
+ __version__='0.15.14',
author='Anthon van der Neut',
author_email='a.van.der.neut@ruamel.eu',
description='ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order', # NOQA
diff --git a/setup.py b/setup.py
index 0ba69be..a0b7f1f 100644
--- a/setup.py
+++ b/setup.py
@@ -263,7 +263,7 @@ try:
_bdist_wheel_available = True
-except ModuleNotFoundError:
+except ImportError:
_bdist_wheel_available = False