summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2017-03-21 17:18:18 +0100
committerAnthon van der Neut <anthon@mnt.org>2017-03-21 17:18:18 +0100
commit9ac44a0873d51d63150b0f1dc1d009b206577a29 (patch)
tree44fc2ecbdba2a6a63544097d7b9f63d8f87d5aae /Makefile
parentc8568f99215aaa910953287f63a25459e3800dfc (diff)
downloadruamel.yaml-9ac44a0873d51d63150b0f1dc1d009b206577a29.tar.gz
update for mypy --strict, prepare de-inheritance (Loader/Dumper)0.14.0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 27b7895..fb69498 100644
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,7 @@ gen_win_whl:
python2 setup.py bdist_wheel --plat-name win_amd64
python3 setup.py bdist_wheel --plat-name win32
python3 setup.py bdist_wheel --plat-name win_amd64
- #@python make_win_whl.py dist/$(PKGNAME)-$(VERSION)-*-none-any.whl
+ # @python make_win_whl.py dist/$(PKGNAME)-$(VERSION)-*-none-any.whl
clean: clean_common
find . -name "*py.class" -exec rm {} +
@@ -20,15 +20,27 @@ cython: ext/_yaml.c
ext/_yaml.c: ext/_yaml.pyx
cd ext; cython _yaml.pyx
-
+
ls-l:
ls -l dist/*$(VERSION)*
+pytest:
+ py.test _test/*.py
+
+MYPYSRC:=$(shell ls -1 *.py | grep -Ev "^(setup.py|.*_flymake.py)$$" | sed 's|^|ruamel/yaml/|')
+MYPYOPT:=--py2 --strict
+
mypy:
cd ..; mypy --strict --no-warn-unused-ignores yaml/*.py
+# sleep to give time to flymake*.py to disappear
mypy2:
- cd ../.. ; mypy --py2 --strict --no-strict-boolean --no-warn-unused-ignores ruamel/yaml/*.py
+ cd ../.. ; mypy $(MYPYOPT) $(MYPYSRC)
+
+mypy2single:
+ @echo 'mypy *.py'
+ @cd ../.. ; mypy $(MYPYOPT) $(MYPYSRC) | fgrep -v ordereddict/__init | grep .
+# @echo 'mypy ' $(MYPYSRC)
#tstvenv: testvenv testsetup testtest
#