summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-09-12 22:16:17 +0200
committerAnthon van der Neut <anthon@mnt.org>2015-09-12 22:16:17 +0200
commite34e17cd001747a82847e7f86f64a8f91bc86653 (patch)
tree6e6f4fbea6be462ceeb1c3d483ecdcdc4dbc1e8e /Makefile
parent0d08f29f24890f1879866b26e0d786ccdbbe880b (diff)
downloadruamel.yaml-e34e17cd001747a82847e7f86f64a8f91bc86653.tar.gz
- modifications to get _yaml.pyx working again
- disable old PyYAML tests as they use open() without explicit close thereby running out of file handles (too much to fix for now)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 951c6fb..e598faa 100644
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,11 @@ gen_win_whl:
clean: clean_common
+cython: ext/_yaml.c
+
+ext/_yaml.c: ext/_yaml.pyx
+ cd ext; cython _yaml.pyx
+
#tstvenv: testvenv testsetup testtest
#