summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2017-03-16 08:50:30 +0100
committerAnthon van der Neut <anthon@mnt.org>2017-03-16 08:50:30 +0100
commitf75754aa90ea4d53f87aba5fce692185a25514c3 (patch)
tree678c37afebe1efd786d513e222a053a3cfe76a07 /Makefile
parent65537ac45d2fe35a98322aea5e6056baa1aefd8a (diff)
downloadruamel.yaml-f75754aa90ea4d53f87aba5fce692185a25514c3.tar.gz
some changes for mypy --strict
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index cebdacf..770f63e 100644
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,12 @@ ext/_yaml.c: ext/_yaml.pyx
ls-l:
ls -l dist/*$(VERSION)*
+mypy:
+ cd ..; mypy --strict --no-warn-unused-ignores yaml/*.py
+
+mypy2:
+ cd ..; mypy --py2 --strict --no-strict-boolean --no-warn-unused-ignores yaml/*.py
+
#tstvenv: testvenv testsetup testtest
#
#testvenv: