diff options
author | Anthon van der Neut <anthon@mnt.org> | 2016-04-07 10:08:01 +0200 |
---|---|---|
committer | Anthon van der Neut <anthon@mnt.org> | 2016-04-07 10:08:01 +0200 |
commit | a35ac83fc1ac46c77c068de132adda0996a7cdf4 (patch) | |
tree | 29f4d1335aa50cc76978a8d44f2225b26cfeb5f5 /setup.py | |
parent | b77c25af71852323adef88d59d722f163db8627e (diff) | |
download | ruamel.yaml-a35ac83fc1ac46c77c068de132adda0996a7cdf4.tar.gz |
1.2 version on round_trip_output (Yes/No/On/Off non-quoted)0.11.8
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -1,7 +1,7 @@ # # header # coding: utf-8 -from __future__ import print_function, absolute_import, division +from __future__ import print_function, absolute_import, division, unicode_literals # # __init__.py parser @@ -284,6 +284,9 @@ class NameSpacePackager(object): x = os.path.join(d, '__init__.py') if os.path.exists(x): self._split.append(self.full_package_name + '.' + d) + if sys.version_info < (3, ): + self._split = [(y.encode('utf-8') if isinstance(y, unicode) else y) + for y in self._split] return self._split @property |