summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2014-11-23 16:39:23 +0100
committerAnthon van der Neut <anthon@mnt.org>2014-11-23 16:39:23 +0100
commit50d2b57039dff86dd090ef9a124861d15f380053 (patch)
treead999f79badab01c8a00825d4ca8c47c65c7d23f /setup.py
parentd709fb8be80a54e793f7eb5a148cd1fa5103933c (diff)
downloadruamel.yaml-50d2b57039dff86dd090ef9a124861d15f380053.tar.gz
- add ext/_yaml.c etc to the source tree
- tests for yaml to work on 2.6/3.3/3.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 19 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 174b452..7b29b5e 100644
--- a/setup.py
+++ b/setup.py
@@ -118,7 +118,18 @@ def main():
# install_requires.append("")
packages = [full_package_name] + [
(full_package_name + '.' + x)
- for x in find_packages('py', exclude=['tests'])]
+ for x in find_packages('py', exclude=['test'])]
+ ext_modules = [
+ # Extension('_yaml', ['ext/_yaml.pyx'],
+ # 'libyaml', "LibYAML bindings", LIBYAML_CHECK,
+ # libraries=['yaml']),
+ Extension(
+ '_yaml',
+ sources=['ext/_yaml.c'],
+ libraries=['yaml'],
+ ),
+ ]
+ ext_modules = []
setup(
name=full_package_name,
version=version_str,
@@ -133,6 +144,7 @@ def main():
package_dir={full_package_name: 'py'},
namespace_packages=[name_space],
packages=packages,
+ ext_modules=ext_modules,
entry_points=mk_entry_points(full_package_name),
cmdclass={'install_lib': MyInstallLib},
classifiers=[
@@ -141,6 +153,12 @@ def main():
'License :: OSI Approved :: MIT License',
'Operating System :: OS Independent',
'Programming Language :: Python',
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Text Processing :: Markup",
]
)