summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-03-18 19:34:26 +0100
committerAnthon van der Neut <anthon@mnt.org>2015-03-18 19:34:26 +0100
commitafdc24a93260e9869361cb7e9855740d2dbd04d3 (patch)
treeaee0b746d9a534b49588054ba2259cfdbb52c73f /setup.py
parent395f2aad5e097b6f65f0ec366eb6b5c4377453f9 (diff)
downloadruamel.yaml-afdc24a93260e9869361cb7e9855740d2dbd04d3.tar.gz
now installs and tests for pypy (by testing in setup.py and not
depending on ruamel.ordereddict if not CPython 2.x series)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 22be0f1..d02e05f 100644
--- a/setup.py
+++ b/setup.py
@@ -5,6 +5,7 @@ from __future__ import print_function
import sys
import os
+import platform
from textwrap import dedent
name_space = 'ruamel'
@@ -151,7 +152,8 @@ def main():
"ruamel.std.argparse>=0.5.1",
]
# use fast ordereddict for !!omap
- if sys.version_info[0] == 2:
+ if sys.version_info[0] == 2 and \
+ platform.python_implementation() == "CPython":
install_requires.extend(['ruamel.ordereddict'])
# if sys.version_info < (3, 4):
# install_requires.append("")
@@ -185,6 +187,8 @@ def main():
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Text Processing :: Markup",
]