diff options
author | Anthon van der Neut <anthon@mnt.org> | 2017-01-22 11:35:48 +0100 |
---|---|---|
committer | Anthon van der Neut <anthon@mnt.org> | 2017-01-22 11:35:48 +0100 |
commit | c86bc3f31f6baee3db7d719455f94712ec375e79 (patch) | |
tree | 0beb7bdcef755ee72aeae78a5387980704174f42 /setup.py | |
parent | 73615a8f615632ce877066420d9b6e6b45a480f4 (diff) | |
download | ruamel.yaml-c86bc3f31f6baee3db7d719455f94712ec375e79.tar.gz |
fix #93: extra empty line inserted on roundtrip0.13.10
This happened only on comments between indented sequence elements
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -586,6 +586,11 @@ class NameSpacePackager(object): to be installed explicitly as they are not on PyPI install_requires should be dict, with keys 'any', 'py27' etc or a list (which is as if only 'any' was defined + + ToDo: update with: pep508 conditional dependencies + https://www.python.org/dev/peps/pep-0508/ + https://wheel.readthedocs.io/en/latest/index.html#defining-conditional-dependencies + https://hynek.me/articles/conditional-python-dependencies/ """ if self._pkg[0] is None: self._pkg[0] = [] @@ -683,7 +688,7 @@ class NameSpacePackager(object): sources=[self.pn(x) for x in target['src']], libraries=[self.pn(x) for x in target.get('lib')], ) - self._ext_modules.append(ext) + self._ext_modules.append(ext) return self._ext_modules print('sys.argv', sys.argv) |