summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-05-28 12:50:15 +0200
committerAnthon van der Neut <anthon@mnt.org>2015-05-28 12:50:15 +0200
commit289970ec0900d8b44b25137361a2e70e0f99d10e (patch)
tree42b498a57d5d59d8de8226976e1aff9c60386b46 /setup.py
parent59d53c586983dd5cb2ee6cfc7111dd233f50cddd (diff)
downloadruamel.yaml-289970ec0900d8b44b25137361a2e70e0f99d10e.tar.gz
- tests run on windows 2.6. and 2.7 (3.3/3.4 have someinstall problems)
- generate .whl for various windows version/platform combination (universal)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1f79a25..4d58ffd 100644
--- a/setup.py
+++ b/setup.py
@@ -63,9 +63,14 @@ version_str = _check_convert_version(version_info)
if __name__ == '__main__':
# put here so setup.py can be imported more easily
- from setuptools import setup, find_packages, Extension
+ from setuptools import setup, find_packages, Extension, Distribution
from setuptools.command import install_lib
+ # windows things this is pure, that way you would get pure python
+ # whl files that take precedence on Linux over source with compilable C
+ Distribution.is_pure = lambda *args: True
+
+
class MyInstallLib(install_lib.install_lib):
"create __init__.py on the fly"