diff options
author | Anthon van der Neut <anthon@mnt.org> | 2016-02-16 21:16:30 +0100 |
---|---|---|
committer | Anthon van der Neut <anthon@mnt.org> | 2016-02-16 21:16:30 +0100 |
commit | a5f5028c7d5623a13b392d8e9bdb9be622476f8c (patch) | |
tree | 8622585e8067711fcd86cda71d289f46b1309b75 /setup.py | |
parent | 64c39f0c0b38bcac13cb4c31429b5e3caadf278e (diff) | |
download | ruamel.yaml-a5f5028c7d5623a13b392d8e9bdb9be622476f8c.tar.gz |
- make sure there is a space before # if scalar pushes (through indent)
a comment from its original column
- flake 8
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 14 |
1 files changed, 6 insertions, 8 deletions
@@ -548,6 +548,12 @@ class NameSpacePackager(object): return None if sys.platform == "win32" and not self._pkg_data.get('win32bin'): return None + try: + plat = sys.argv.index('--plat-name') + if 'win' in sys.argv[plat+1]: + return None + except ValueError: + pass import tempfile import shutil from textwrap import dedent @@ -622,8 +628,6 @@ class NameSpacePackager(object): print("\n\n>>>>>> LICENSE file not found <<<<<\n\n") if self._pkg_data.get('universal'): fp.write('[bdist_wheel]\nuniversal = 1\n') - else: - fp.write('[bdist_wheel]\nuniversal = 0\n') try: setup(**kw) except: @@ -633,11 +637,6 @@ class NameSpacePackager(object): return True -class BinaryDistribution(Distribution): - def is_pure(self): - return False - - # # call setup def main(): dump_kw = '--dump-kw' @@ -668,7 +667,6 @@ def main(): keywords=nsp.keywords, package_data=nsp.package_data, ext_modules=nsp.ext_modules, - distclass=BinaryDistribution, ) if '--version' not in sys.argv and ('--verbose' in sys.argv or dump_kw in sys.argv): for k in sorted(kw): |