summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index cebdacf..770f63e 100644
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,12 @@ ext/_yaml.c: ext/_yaml.pyx
ls-l:
ls -l dist/*$(VERSION)*
+mypy:
+ cd ..; mypy --strict --no-warn-unused-ignores yaml/*.py
+
+mypy2:
+ cd ..; mypy --py2 --strict --no-strict-boolean --no-warn-unused-ignores yaml/*.py
+
#tstvenv: testvenv testsetup testtest
#
#testvenv: