summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polyconseil.fr>2015-07-02 16:20:25 +0200
committerRaphaël Barrois <raphael.barrois@polyconseil.fr>2015-07-02 16:35:57 +0200
commitee65fd925dc5bf7ff388e997b7ffa5726c00898e (patch)
tree13a556df6fadf404b47b6cb5347ff0e7799aa780 /.travis.yml
parent2174bdcae6e46f5f68f5b8ea984a695db9f41bcf (diff)
downloadsemantic-version-ee65fd925dc5bf7ff388e997b7ffa5726c00898e.tar.gz
Switch to django-version-dependant install scheme.
Also update travis to use it.
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml18
1 files changed, 12 insertions, 6 deletions
diff --git a/.travis.yml b/.travis.yml
index d4ebed3..a393a8c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,13 +1,19 @@
language: python
+
+env:
+ - DJANGO_VERSION=1.4
+ - DJANGO_VERSION=1.6
+ - DJANGO_VERSION=1.8
+
python:
- - "2.6"
- "2.7"
- - "3.2"
- - "3.3"
- "3.4"
-script: "python setup.py test"
-install: "if [[ $TRAVIS_PYTHON_VERSION = 2.6 ]]; then pip install unittest2 --use-mirrors; fi"
+script:
+ - python setup.py test
+
+install:
+ - make install-deps
+
notifications:
email: false
irc: "irc.freenode.org#xelnext"
-