summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 10:36:16 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 10:36:16 +0100
commite24cc2e4d2e2d6aabacfb530c6815926ec1d3902 (patch)
treef7700bdb5abfeddee813cd87445687c3c1d7c6c4
parent88b077b1cc19a4754ef004ff0ca07c3d2bb8ef19 (diff)
downloadsemantic-version-cleaner-runtest.tar.gz
Run tests through unittest directlycleaner-runtest
Instead of using `python setup.py test` (which is deprecated), move to the standard `python -m unittest`.
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c94363c..dd44400 100644
--- a/Makefile
+++ b/Makefile
@@ -47,7 +47,7 @@ testall:
# DOC: Run tests for the currently installed version
test:
- python -Wdefault setup.py test
+ python -Wdefault -m unittest
# DOC: Perform code quality tasks
lint: check-manifest flake8