summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 11:22:23 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 11:30:48 +0100
commitdf3fc6da3a870aff7d5c35dbd9f76ff5bd0b6ab2 (patch)
tree5eecda8ac882c7360e0919d383af3e69b20eb6c2
parent33c67cb1d12ec43346cd6971bfdcf9561e718fa0 (diff)
downloadsemantic-version-df3fc6da3a870aff7d5c35dbd9f76ff5bd0b6ab2.tar.gz
Replace setup.py test with nose2
We can't use python -m unittest discover directly, as it mistakenly tries to import the source code of the Django test app without going through the setup_django module first.
-rw-r--r--Makefile2
-rw-r--r--setup.cfg1
2 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 6871485..c617168 100644
--- a/Makefile
+++ b/Makefile
@@ -47,7 +47,7 @@ testall:
# DOC: Run tests for the currently installed version
test:
- python -Wdefault setup.py test
+ python -Wdefault -m nose2
# DOC: Perform code quality tasks
lint: check-manifest flake8
diff --git a/setup.cfg b/setup.cfg
index 778ba33..799dba3 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -36,6 +36,7 @@ install_requires =
dev =
Django>=1.11
# Runners
+ nose2
tox
# Quality
check_manifest