summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2016-02-12 01:30:21 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2016-02-12 01:30:43 +0100
commit472e9e402704a345102168b7bf32c3637f86259c (patch)
tree47ccde5d3d4af097dd3885b8b94aeac180904fd0
parent52f57bb0fd9bd6edeb71d9d517069dca6531565e (diff)
downloadsemantic-version-472e9e402704a345102168b7bf32c3637f86259c.tar.gz
Test up to 3.5v2.5.0
-rw-r--r--.travis.yml1
-rw-r--r--README.rst16
-rwxr-xr-xsetup.py4
3 files changed, 17 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 2215483..4219923 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,6 +3,7 @@ language: python
python:
- "2.7"
- "3.4"
+ - "3.5"
env:
- DJANGO_VERSION=1.7
- DJANGO_VERSION=1.8
diff --git a/README.rst b/README.rst
index 7389009..71ebe98 100644
--- a/README.rst
+++ b/README.rst
@@ -7,7 +7,21 @@ It follows strictly the 2.0.0 version of the SemVer scheme.
.. image:: https://secure.travis-ci.org/rbarrois/python-semanticversion.png?branch=master
:target: http://travis-ci.org/rbarrois/python-semanticversion/
-semantic_version supports Python 2.6, 2.7, 3.2, 3.3, 3.4; and is distributed under the two-clause BSD license.
+.. image:: https://img.shields.io/pypi/v/semantic_version.svg
+ :target: http://python-semanticversion.readthedocs.org/en/latest/changelog.html
+ :alt: Latest Version
+
+.. image:: https://img.shields.io/pypi/pyversions/semantic_version.svg
+ :target: https://pypi.python.org/pypi/semantic_version/
+ :alt: Supported Python versions
+
+.. image:: https://img.shields.io/pypi/wheel/semantic_version.svg
+ :target: https://pypi.python.org/pypi/semantic_version/
+ :alt: Wheel status
+
+.. image:: https://img.shields.io/pypi/l/semantic_version.svg
+ :target: https://pypi.python.org/pypi/semantic_version/
+ :alt: License
Links
-----
diff --git a/setup.py b/setup.py
index 6baac7d..9c23b3b 100755
--- a/setup.py
+++ b/setup.py
@@ -61,12 +61,10 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Topic :: Software Development :: Libraries :: Python Modules'
],
test_suite='tests',