summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2016-02-21 18:52:45 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2016-02-21 18:52:45 +0100
commit9872b3940e87d1d810560ea4381929554fd8038c (patch)
tree049d1bccf46cb0fbd971de6596c24887ab53094c
parenta03a88105540d60449c40ecc98b111cc387121a8 (diff)
downloadsemantic-version-9872b3940e87d1d810560ea4381929554fd8038c.tar.gz
lint: Remove double return.
-rw-r--r--semantic_version/base.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/semantic_version/base.py b/semantic_version/base.py
index cf85d86..8877dbf 100644
--- a/semantic_version/base.py
+++ b/semantic_version/base.py
@@ -460,7 +460,6 @@ class SpecItem(object):
return version != self.spec
elif self.kind == self.KIND_CARET:
return self.spec <= version < self.spec.next_major()
- return self.caret_compare(version)
elif self.kind == self.KIND_TILDE:
return self.spec <= version < self.spec.next_minor()
else: # pragma: no cover