summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml18
1 files changed, 12 insertions, 6 deletions
diff --git a/.travis.yml b/.travis.yml
index d4ebed3..a393a8c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,13 +1,19 @@
language: python
+
+env:
+ - DJANGO_VERSION=1.4
+ - DJANGO_VERSION=1.6
+ - DJANGO_VERSION=1.8
+
python:
- - "2.6"
- "2.7"
- - "3.2"
- - "3.3"
- "3.4"
-script: "python setup.py test"
-install: "if [[ $TRAVIS_PYTHON_VERSION = 2.6 ]]; then pip install unittest2 --use-mirrors; fi"
+script:
+ - python setup.py test
+
+install:
+ - make install-deps
+
notifications:
email: false
irc: "irc.freenode.org#xelnext"
-