summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 626f21c..ecf30e0 100644
--- a/Makefile
+++ b/Makefile
@@ -32,9 +32,13 @@ test:
python -W default setup.py test
# Note: we run the linter in two runs, because our __init__.py files has specific warnings we want to exclude
-lint:
+lint: check-manifest flake8
+
+check-manifest:
check-manifest
- $(FLAKE8) --config .flake8 --exclude $(PACKAGE)/__init__.py $(PACKAGE)
+
+flake8:
+ $(FLAKE8) --config .flake8 --exclude $(PACKAGE)/__init__.py $(PACKAGE) $(TESTS_DIR)
$(FLAKE8) --config .flake8 --ignore F401 $(PACKAGE)/__init__.py
coverage: