summaryrefslogtreecommitdiff
path: root/semantic_version/base.py
diff options
context:
space:
mode:
Diffstat (limited to 'semantic_version/base.py')
-rw-r--r--semantic_version/base.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/semantic_version/base.py b/semantic_version/base.py
index 83a9c25..0f4e11b 100644
--- a/semantic_version/base.py
+++ b/semantic_version/base.py
@@ -470,7 +470,7 @@ class SpecItem(object):
elif self.kind == self.KIND_TILDE:
return self.spec <= version < self.spec.next_minor()
elif self.kind == self.KIND_COMPATIBLE:
- if self.spec.patch:
+ if self.spec.patch is not None:
upper = self.spec.next_minor()
else:
upper = self.spec.next_major()