summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2013-08-14 14:06:06 +0800
committerYu-Jie Lin <livibetter@gmail.com>2013-08-14 14:06:06 +0800
commitccf9c2338e95b4436ed5a73d3585e25602e4b32b (patch)
tree9aa51ea0b6904cf5d05855ebde700e50353357ba
parent7f138eb8923c1eda0e8ff5fd8d0f1968cfdeba64 (diff)
downloadsmartypants-ccf9c2338e95b4436ed5a73d3585e25602e4b32b.tar.gz
add Makefile to ensure same release fashion every time
-rw-r--r--.hgignore1
-rw-r--r--Makefile9
2 files changed, 10 insertions, 0 deletions
diff --git a/.hgignore b/.hgignore
index ec2ea52..e6efb62 100644
--- a/.hgignore
+++ b/.hgignore
@@ -1,3 +1,4 @@
syntax: glob
+build
dist
MANIFEST
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1ee1f8c
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,9 @@
+BUILD_CMD=./setup.py sdist --formats gztar,zip bdist_wininst --plat-name win32
+
+build:
+ $(BUILD_CMD)
+
+upload:
+ $(BUILD_CMD) upload
+
+.PHONY: build upload