summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorshimizukawa <shimizukawa@gmail.com>2014-09-01 23:16:54 +0900
committershimizukawa <shimizukawa@gmail.com>2014-09-01 23:16:54 +0900
commitca9a3fac103d1b37468204c5f552ba2f34793c0e (patch)
tree1e496760554d70cd55c9fa74ef377fb8c9f2ed53
parent13e3eaa7acb297c114aa8f9cb72e338a818c96ff (diff)
downloadsphinx-ca9a3fac103d1b37468204c5f552ba2f34793c0e.tar.gz
run `make check` and correct errors.
-rw-r--r--setup.py3
-rw-r--r--sphinx/ext/autosummary/__init__.py6
2 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index d35c886f..9872226e 100644
--- a/setup.py
+++ b/setup.py
@@ -136,7 +136,8 @@ else:
jscatalog = {}
for message in catalog:
- if any(x[0].endswith(('.js', '.js_t', '.html')) for x in message.locations):
+ if any(x[0].endswith(('.js', '.js_t', '.html'))
+ for x in message.locations):
msgid = message.id
if isinstance(msgid, (list, tuple)):
msgid = msgid[0]
diff --git a/sphinx/ext/autosummary/__init__.py b/sphinx/ext/autosummary/__init__.py
index 906b3c20..c5c8f151 100644
--- a/sphinx/ext/autosummary/__init__.py
+++ b/sphinx/ext/autosummary/__init__.py
@@ -269,12 +269,14 @@ class Autosummary(Directive):
# try to also get a source code analyzer for attribute docs
try:
- documenter.analyzer = ModuleAnalyzer.for_module(documenter.get_real_modname())
+ documenter.analyzer = ModuleAnalyzer.for_module(
+ documenter.get_real_modname())
# parse right now, to get PycodeErrors on parsing (results will
# be cached anyway)
documenter.analyzer.find_attr_docs()
except PycodeError, err:
- documenter.env.app.debug('[autodoc] module analyzer failed: %s', err)
+ documenter.env.app.debug(
+ '[autodoc] module analyzer failed: %s', err)
# no source file -- e.g. for builtin and C modules
documenter.analyzer = None