summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml12
-rw-r--r--test-reqs.txt8
2 files changed, 18 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 54e27e20..88999204 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,7 +1,15 @@
language: python
python:
+ - "2.6"
- "2.7"
- "3.3"
-script: make test
+ - "3.4"
+ - "pypy"
+env:
+ - DOCUTILS=0.10
+ - DOCUTILS=0.11
+ - DOCUTILS=0.12
install:
- - python setup.py -q install
+ - pip install docutils==$DOCUTILS
+ - pip install -r test-reqs.txt
+script: make test
diff --git a/test-reqs.txt b/test-reqs.txt
new file mode 100644
index 00000000..43260f87
--- /dev/null
+++ b/test-reqs.txt
@@ -0,0 +1,8 @@
+six>=1.4
+Jinja2>=2.3
+Pygments>=1.2
+docutils>=0.10
+snowballstemmer>=1.1
+babel
+sqlalchemy>=0.9
+whoosh>=2.0