summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2014-07-09 15:50:17 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2014-07-09 15:50:17 -0400
commit99350b159f736fe8c2c95eabb4d332d9fab73eb9 (patch)
treed1e9e41060a7b007051ca6513f5759ead7009057
parent450453ab1a5f5a1ce86d6f9dba6f1ae5f30c8f92 (diff)
downloadsqlalchemy-99350b159f736fe8c2c95eabb4d332d9fab73eb9.tar.gz
- Fixed bug where "python setup.py test" wasn't calling into
distutils appropriately, and errors would be emitted at the end of the test suite.
-rw-r--r--doc/build/changelog/changelog_09.rst8
-rw-r--r--lib/sqlalchemy/testing/distutils_run.py10
-rw-r--r--setup.py2
3 files changed, 19 insertions, 1 deletions
diff --git a/doc/build/changelog/changelog_09.rst b/doc/build/changelog/changelog_09.rst
index 27baca127..eaa16cf3e 100644
--- a/doc/build/changelog/changelog_09.rst
+++ b/doc/build/changelog/changelog_09.rst
@@ -15,6 +15,14 @@
:released:
.. change::
+ :tags: bug, tests
+ :versions: 1.0.0
+
+ Fixed bug where "python setup.py test" wasn't calling into
+ distutils appropriately, and errors would be emitted at the end
+ of the test suite.
+
+ .. change::
:tags: feature, postgresql
:versions: 1.0.0
:pullreq: bitbucket:22
diff --git a/lib/sqlalchemy/testing/distutils_run.py b/lib/sqlalchemy/testing/distutils_run.py
new file mode 100644
index 000000000..d8f8f5931
--- /dev/null
+++ b/lib/sqlalchemy/testing/distutils_run.py
@@ -0,0 +1,10 @@
+"""Quick and easy way to get setup.py test to run py.test without any
+custom setuptools/distutils code.
+
+"""
+import unittest
+import pytest
+
+class TestSuite(unittest.TestCase):
+ def test_sqlalchemy(self):
+ pytest.main()
diff --git a/setup.py b/setup.py
index ae4f8416c..81e388874 100644
--- a/setup.py
+++ b/setup.py
@@ -129,7 +129,7 @@ def run_setup(with_cext):
license="MIT License",
cmdclass=cmdclass,
tests_require=['pytest >= 2.5.2', 'mock'],
- test_suite="pytest.main",
+ test_suite="sqlalchemy.testing.distutils_run",
long_description=readme,
classifiers=[
"Development Status :: 5 - Production/Stable",